eKO NARwoyo

Thursday, June 5, 2008

Tutorial sederhana ( hanya 3 langkah ) ini sangat bermanfaat bagi RT/RW net atau warnet yang ingin melakukan optimalisasi bandwidth dengan melakukan queue traffic download dari file-file tertentu.

Sudah menjadi masalah klasik ketika bandwidth warnet / RT/RW net harus habis karena ada salah satu client/user rakus bandwidth melakukan downloading .

Tentunya dengan simpe queue sederhana hal ini bisa diatasi.

Tapi bagaimana jika client awam tetap ingin browsing itu lancar meskipun mereka sedang download file.

Client yang aneh …

Berikut tutorial untuk melakukan limitasi bandwidth dari DataUtamaNet untuk melimit traffic download extension file2 tertentu.

Disini kita akan memanfaatkan fasilitas content, address list, mangle dan simple queue dari mikrotik.

Kita asumsikan Router Mikrotiik sudah terinstall dengan baik, dalam artian client kita sudah bisa akses internet dengan lancar.

Langkah 1

Kita masukan rule di firewall untuk mendapatkan IP dari download server dan memasukan IP tersebut ke dalam address list

/ip firewall filter add chain=forward \

src-address=192.168.10.0/24 protocol=tcp content=.mp3 \

action=add-dst-to-address-list address-list=downloads \

address-list-timeout=01:00:00

/ip firewall filter add chain=forward \

src-address=192.168.10.0/24 protocol=tcp content=.exe \

action=add-dst-to-address-list address-list=downloads \

address-list-timeout=01:00:00

Rule diatas akan menangkap semua traffic dengan content .mp3 dan .exe yang berasal dari blok IP LAN dan memasukannya ke addres list downloads selama 1 jam.

Variable diatas dapat dirubah sesuai dengan topology dan kebutuhan anda sendiri.

Langkah 2

Kita lakukan mangle untuk marking paket yang berasal dari address list yang telah kita dapat dari Langkah 1

/ip firewall mangle add chain=forward \

protocol=tcp src-address-list=downloads \

action=mark-packet new-packet-mark=download-paket

Mangle ini kita perlukan untuk melabeli paket sehingga simple queue dapat menangkap traffic dari IP-IP yang telah terdapat pada address list “downloads”

Langkah 3

Langkah terakhir kita masukkan simple queue dari paket mark yang telah kita dapet dari langkah 2

/queue simple add name=download-files \

max-limit=64000/64000 packet-marks=download-paket

Letakan queue di urutan paling atas supaya dibaca dulu oleh mikortik

That’s it ..

Kita sudah berhasil mengalokasikan bandwidth untuk traffic download file2 yang kita inginkan, dan browsing tetap lancar .. meskipun browsing ke server yang sudah pada address list menjadi lambat karena ikut ke limit ;-) at least for the next 1 hour J




posted by eKO NARwoyo at 4:28 PM

1 Comments:

pak eno yang erhormat setelah scrip di atas ak pasang di routere kok ngak ada IP addess yg ketangkep di acceslist ya?? mohon pencerahannya boss

July 22, 2008 at 6:09 AM  

Post a Comment

<< Home